Samstag, 29. Juli 2006

Hello and good-bye until we meet again

Darius 15.47 Uhr Filed under: Alles und nichtsIntypo

Since my provider has killed my complete server content (and reminded me to make a backup afterwards!), it will still take a while until everything will be runnig as it used to.

I’m sorry, InTypo is not available for the moment. InTypo 0.6.4 is available again from my Download page.

InTypo ist leider derzeit nicht verfügbar. auf der Download-Seite in Version 0.6.4 erhältlich.

12 Comments »

  1. Schön, dass Du wieder da bist. Ich glaube ich hatte das schon mal irgendwo geschrieben, aber dieses wunderbare (!) Plugin scheint einen kleinen Bug zu haben.

    »(a href=“http://domain.com“)DOMAIN.COM(/a)«.
    »DOMAIN.COM«

    »(a href=“http://domain.com“)DOMAIN.COM(/a)«!
    »DOMAIN.COM«!

    »(a href=“http://domain.com“)DOMAIN.COM(/a)«?
    »DOMAIN.COM«?

    Das letzte Anführungszeichen ist in diesen Fällen falsch.
    WordPress 2.x, PHP 5.x

    Ich habe mir vorübergehen mal damit beholfen:

    $fix = array( $ity_quot[$mark][0].‹!', $ity_quot[$mark][0].‹?', $ity_quot[$mark][0].‹.', $ity_quot[$mark][0].‹,', $ity_quot[$mark][0].‹)', $ity_quot[$mark][0].‹]');
    $replace = array( $ity_quot[$mark][1].‹!', $ity_quot[$mark][1].‹?', $ity_quot[$mark][1].‹.', $ity_quot[$mark][1].‹,', $ity_quot[$mark][1].‹)', $ity_quot[$mark][1].‹]');
    $content = str_replace($fix,$replace,$content);

    Sicher nicht die sauberste Lösung. 🙂

    — Comment by Funbug am Mittwoch, 2. August 2006 um 23.55 Uhr

  2. »Nicht die sauberste Lösung«, so präsentiert sich offenbar auch mein neues Design, wie man hier sieht sah. Aber klar, die Darstellung von Code hatte ich mir noch nicht vorgeknöpft.

    Das Problem mit den falschen Anführungszeichen hattest du tatsächlich schonmal beschrieben. Ich werde mich demnächst endlich mal darum kümmern, wie die Erkennung noch verbessert werden kann. Ich glaube, es gibt noch ein paar weitere Fälle, in denen falsch ersetzt wird.
    Ich schätze aber, dass das Fälle sind, in denen auch die normale (englische) Anführungszeichen-Ersetzung von WordPress fehlschlägt. Die Abfragen im Code, um welche Art von Anführungszeichen es sich kontextabhängig handeln müsste, stammen ja größtenteils aus der ursprünglichen WordPress-Funktion.

    — Comment by Darius am Donnerstag, 3. August 2006 um 0.11 Uhr

  3. Hehe ja, ich bin auch zuerst erschrocken. 🙂

    Ich hatte teilweise noch ein paar andere Probleme. Ich habe das ähnlich unschön wie oben gelöst. Ich denke inzwischen sollte bei mir alles wie gewünscht funktionieren.

    Ich habe dir den Code mal per E-Mail geschickt. Vielleicht kannst du damit was anfangen.

    Ich finde es eh ziemlich schwach, dass WordPress das nicht selbst sauber hinbekommt. Deswegen ist dein Plugin für mich auch unabdingbar und freue mich auf eine hoffentlich bald aktualisierte Version. 🙂

    Wenn das Plugin fehlerfrei läuft und wirklich alles korrekt ersetzt solltest du unbedingt mal vorschlagen, dass es in den WP-Core aufgenommen wird.

    — Comment by Funbug am Freitag, 4. August 2006 um 11.46 Uhr

  4. Ich bin so froh, dass es dieses Plugin gibt. Leider scheint es nicht in alle Ecken zu reichen: Bei dem Tarksi Theme bleiben zum Beispiel die Anführungszeichen im Footer und in der Sidebar völlig unbeeinflusst. Besteht die Ausschicht, das irgendwie zu ändern?

    — Comment by Andreas am Freitag, 17. November 2006 um 15.00 Uhr

  5. Ich schätze nein. Soweit ich das auswendig überblicke, sind Eingriffe in Footer und Sidebar leider nicht so ohne weiteres über ein normales Plugin zu verwirklichen, weil es dafür keine Schnittstellen gibt.

    — Comment by Darius am Freitag, 17. November 2006 um 18.48 Uhr

  6. Ich habe das Plugin »Intypo« installiert, aber leider ein Problem: Ich habe folgende Option gewählt:
    »Lorem ipsum ›dolor‹ sit amet.« (Croatian / Czech / Danish / German / Latvian / Lithuanian / Polish / Slovakian)

    Mir hat nämlich die üblichen deutschen Anführungszeichen (unten/oben) nicht gefallen. Nun werden aber in der Headline die Anführungszeichen nicht richtig angezeigt:
    »Zur Linde»

    Wie kann ich das denn beeinflussen?

    — Comment by Barbara am Sonntag, 19. November 2006 um 18.48 Uhr

  7. Jetzt habe ich die Lösung des Problems gefunden. WordPress scheint Probleme damit zu haben, die Anführungszeichen bei einem Wort zu erkennen, wo zusätzlich noch Klammern drumherum sind: (»Zur Linde»). Es benötigt links und rechts je ein Leerzeichen, um die Anführungszeichen als solche definieren zu können, also so: ( »Zur Linde« )
    Hängt das mit Intypo zusammen oder ist das ien generells WordPressproblem?

    Viele Grüße
    Barbara

    — Comment by Barbara am Sonntag, 19. November 2006 um 23.07 Uhr

  8. Ja, es hängt mit ähnlichen Problemen zusammen, wie im ersten Kommentar oben erwähnt. Ich denke, dass ich ab Mitte Dezember dazu komme, die Anführungszeichen-Erkennung des Plugins zu überarbeiten.
    Aber übrigens haben ja auch Textverarbeitungsprogramme keine 100% zuverlässige Erkennung von Anführungszeichen. Es ist, wenn man alle Sonderfälle berücksichtigen will, ganz schön kompliziert.

    — Comment by Darius am Dienstag, 21. November 2006 um 15.04 Uhr

  9. Hi,

    vielen Dank für dein Plugin. Nur eine kleine Frage: ist es auch auch für verschachtelte Zitate wie »Er rief: »Komm her!«« ausgelegt? Auch bei der Schreibweise »Er rief: ›Komm her!‹« funktioniert das bei den inneren Anführungsstrichen nicht richtig.

    — Comment by user am Samstag, 9. Dezember 2006 um 12.26 Uhr

  10. Ach, es liegt wahrscheinlich an dem Doppelpunkt davor, wo bei mir das Leerzeichen fehlte. Nevermind.

    — Comment by user am Samstag, 9. Dezember 2006 um 12.29 Uhr

  11. Ich möchte mich auch an dieser Stelle für dieses Must-Have-Plugin bedanken. Sollte populärer gemacht werden, definitiv. Funktioniert übrigens im handgemachten Theme problemlos.

    — Comment by MisterBrightside am Dienstag, 19. Dezember 2006 um 19.07 Uhr

  12. @Andreas:
    Die neue Version 0.9.1 beeinflusst jetzt zumindest auch die Schreibweise von Kategorien in der Sidebar.

    @Barbara:
    Jetzt müsste es auch mit Anführungszeichen in Klammern klappen. (»Test«)

    @funbug:
    Anführungszeichen hinter »HTML-Tags« sind manchmal problematisch, aber ich habe auch hier Verbesserungen erreicht.

    — Comment by Darius am Mittwoch, 28. Februar 2007 um 3.34 Uhr

RSS feed for comments on this post. TrackBack URL

Leave a comment